cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Portier <...@outerthought.org>
Subject Re: Cocoon forms problem
Date Wed, 02 Jun 2004 21:40:02 GMT


Bartosz ZgodziƄski wrote:

> Unfortunatelly it's not the end. I don't know where this bug appears but in
> my source file I've got:
>   <fd:field id="opis" required="true">
>       <fd:label>Opis:</fd:label>
>       <fd:datatype base="string"/>
>    <fd:validation>
>       <fd:length min="2" max="4"/>
>    </fd:validation>
>     </fd:field>
> So it's correct and I still have blank page when I write "fafafa" ->
> validation doesn't work :(
> 

odd, I just snatched your above snippet, wrapped in a proper 
<fd:form>e<fd:widgets> and supplied a silly template and flowscript to 
call it all, no props over here: 'a' and 'fafafa' are marked wrong while 
'ere' nicely proceeds the flowscript after the showform

try getting some more info out of things by adding some print statements 
in the flowscript and checking the logs (maybe increasing the log-level)
(maybe even adding some print stuff in the Forms.js around the 
sendPageAndWait part...)

since you see the form at least the first time this must mean that the 
pipeline works ok so there is no reason to juggle around there...

-marc= (running out of ideas)
-- 
Marc Portier                            http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
Read my weblog at                http://blogs.cocoondev.org/mpo/
mpo@outerthought.org                              mpo@apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message