cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geert Van Damme" <geert.vanda...@vdab.be>
Subject internal cocoon NPE'S (was Re: Errors in XSLT transformation)
Date Thu, 13 May 2004 09:58:26 GMT

Did anyone experience this problem in Cocoon2.1 ?
No that this is an option at the moment (not my decision) but I might
install it and run the same tests...

anyone ?


>>> jh@domek.be 05/13/04 11:29am >>>
Eureka !!!

Geert Van Damme wrote:

> Hi all,
> 
> I can't seem to find a lot of information about this, so I hope
someone
> can help me out.

my posts on
http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=108365906801452&w=2

and
http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=108375094018136&w=2 

> 
> I'm using Cocoon 2.0.4.
> 
> Every now and then, I get following exception when creating a PDF
using
> fo2pdf (actually i think the exception occurs in the xslt generating
the
> FO xsl document) :
exactly, you're getting this *every now and then*, just like me. Very 
difficult to pin this down other then "it happens sometimes when doing

multiple requests at the same time".

> 
> org.apache.cocoon.ProcessingException: Exception in
> ServerPagesGenerator.generate(): java.lang.RuntimeException: Errors
in
> XSLT transformation: Fatal: java.lang.NullPointerException
> 
> (full stacktrace is printed below)
> 
> It seems to be occuring at random moments when multiple requests are
> received at the same time. I tried using the latest version of
Xalan,
yup confirmed.

> but the problem still occurs. I tried using XSLTC but this doesn't
work
> at all ("Cocoon Confusion"). Incremental Mode doesn't work either
> (thought this would give me some more info but instead I get an
error,
> coincidently (?) the same exception but in a different place :
yup there are a few places (also seems random) that these nullpointers

can occur.

Keep in mind that this is still 2.0.4, so unlikely to draw much 
attention from dev@cocoon. Hopefully this will change now.


Regards
Jorg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org 
For additional commands, e-mail: users-help@cocoon.apache.org 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message