cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Velychko <v_pe...@ukr.net>
Subject Re: Hibernate 2.1.3 + cocoon + c3p0 jar hell [repost from dev]
Date Tue, 11 May 2004 08:38:42 GMT
Hello Leszek,

I have in production the following configuration:
  tomcat + cocoon 2.1.5-cvs + hibernate 2.1.3 + dbcp.
It works without problem.

Just now I've configured my tomcat to work with c3p0 connection pool
and it works corectly also.

I'll try to start my application on jetty. What version of jetty are
you use?

Sunday, May 9, 2004, 11:57:27 AM, you wrote:

> This is a repost from cocoon-dev list. Maybe someone of cocoon users might
> help me?

> I think there is a serious problem with latest version  of
> hibernate (2.1.3) and cocoon integration. There is some kind of jar problem
> that did not occur with 2.1.2. I have attached a exception log. The problem
> occurs only with hibernate running in cocoon when you want to use c3p0
> connection pooling. When you hit the server the exception gets thrown that you
> cannot obtain the connection because it has already been closed.

> My tests showed that:
> 1. The problem does not occur with hibernate built-in pooling (but this one is 
> unuseable in production environment - at least hibernate web page states that)

> 2. The problem is not a problem of hibernate itself. I have been able to run
> hibernate with c3p0 outside of cocoon and jetty (although all jetty and cocoon
> libs were also on the classpath - really strange - maybe jar order on
> classpath matters).

> 3. The problem is not a problem of c3p0 itself. Hibernate 2.1.3 contains a new
> version of c3p0 (0.8.4.5) but if you downgrade only hibernate2.jar to 2.1.2
> version the problem disapperas.

> 4. The problem is not database dependent. I have tries both MS SQL Server and
> HSQLDB - both do not work with cocoon+hibernate+c3p0.

> I use following libraries that are copies to cocoon lib directory:
> c3p0-0.8.4.5.jar
> cglib-full-2.0.1.jar
> commons-dbcp-1.1.jar
> commons-pool-1.1.jar
> dom4j-1.4.jar
> hibernate2.jar
> jdbc2_0-stdext.jar
> jta.jar
> msbase.jar
> mssqlserver.jar
> msutil.jar
> odmg-3.0.jar

> The rest needed libraries are already in cocoonlib dir (although versions
> differ). Hibernate is using commons collections 2.1 while cocoon uses 3.0 but
> this caused no problems with hib2.1.2

> My regards
>         LG


-- 
Best regards,
Peter Velychko                            
v_peter@ukr.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message