cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Lerche <pe...@easyspeedy.com>
Subject cocoon sitemap/xconf class loading
Date Tue, 18 May 2004 11:26:30 GMT
Hi
I have a problem finding a class defined in my sitemap.xmap file.
The jar i placed outside cocoon /lib /classes directories.

Cocoon finds the classes from the jar on servlet start :
Forced loading a class:
(web.xml)
	<init-param>
            <param-name>load-class</param-name>
            <param-value>org.exist.cocoon.XQueryGenerator</param-value>
        </init-param>


When I the want to use it from my sitemap I get a ClassNotFoundException.

How can I load a class placed in a jar/class structure outside of cocoon. 
Tried several things like entering the full classpath in web.xml:
<init-param>
                  <param-name>extra-classpath</param-name>
                  <param-value>                        
/my/fule/path/jboss-3.2.3/server/default/lib/exist-optional.jar
                  </param-value>
                </init-param>
but nothing seams to effect the sitemap classloader. even tried to substitute 
the class loader to use jboss own classloader but nothing changed. 

Any idea/suggestions are wellcome



Original Exception: java.lang.ClassNotFoundException: 
org.exist.cocoon.XQueryGenerator
        at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at org.mortbay.http.ContextLoader.loadClass(ContextLoader.java:198)
        at org.mortbay.http.ContextLoader.loadClass(ContextLoader.java:171)
        at 
org.apache.cocoon.components.ExtendedComponentSelector.configure(ExtendedComponentSelector.java:232)
-- 



Med venlig hilsen / Yours sincerely 
 
Peter Lerche
http://easyspeedy.com 
_______________________________________ 
European Dedicated Server Hosting 
Extremely low prices, secure, and reliable
Linux and BSD distributions only 
_______________________________________

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message