cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hubert Trzewik" <htrzewik-use...@prosystel.com.pl>
Subject Re: Problems passing parameters to XSP
Date Tue, 20 Apr 2004 15:53:00 GMT
Hi,

XSP:EXPR should be outside of XSP:LOGIC block..

try:

<select>
  <xsp:logic>
   String app_id = <util:get-sitemap-parameter name="app_id"/>;
   String user_id = <util:get-sitemap-parameter name="user_id"/>;
  </xsp:logic>
END OF XSP:LOGIC BLOCK MOVED HERE

   <val1><xsp:expr>app_id</xsp:expr></val1>
   <val2><xsp:expr>user_id</xsp:expr></val2>
</select>

> Hi,
> I know that this is a very well documented subject, but I try it, and
> doesn't work.
>
> My pipeline is:
>    <map:match pattern="test-*-*">
>     <map:generate src="cocoon:/select_bookmark_list.xsp"
> strip-root="false">
>      <map:parameter name="user_id" value="{1}"/>
>      <map:parameter name="app_id" value="{2}"/>
>     </map:generate>
>     <map:serialize type="xml"/>
>    </map:match>
>
> My xsp file is:
>  <select>
>   <xsp:logic>
>    String app_id = <util:get-sitemap-parameter name="app_id"/>;
>    String user_id = <util:get-sitemap-parameter name="user_id"/>;
>    <val1><xsp:expr>app_id</xsp:expr></val1>
>    <val2><xsp:expr>user_id</xsp:expr></val2>
>   </xsp:logic>
>  </select>
>
> The xsp can't pull the parameters. The result is an empty string. I
> already try to use the parameters.getParameter("paramname")
> but the problem is the same. Can anybody tell me what's wrong here?!
>
> Thanks,
> Carlos Dias
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message