cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mariusz Wojcik" <wojc...@okno.pw.edu.pl>
Subject Coplets, cl:link - problems with sending and receiving parameters
Date Sun, 18 Apr 2004 20:31:26 GMT
Hi I'm using new Cocoon Portal Engine (C. 2.1.4), and I have to send parameters between coplets
(their context is generated by xsp pages). 

I have set coplet attribute in my copletdata portal.xml file:
************************************
(coplet data) portal.xml
************************************
<coplet-data id="Pracownicy" name="standard">
.................
<attribute>
<name>id</name><!-- My attribute name-->
<value xsi:type="java:java.lang.String" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">Hello</value>
<!-- My attribute default value-->
</attribute>
</coplet-data>

************************************

In the first xsp file I'm using cl:links commands to reload content, and setting "id" attribute
value:
************************************
first xsp file
************************************
.............................................
<cl:links>
 <cl:link coplet="Pracownicy-1 path="copletData/attributes/id value="New_Value"/> <!--
setting up id value--> 
 <p> 
  <cl:link coplet="Pracownicy-1"
             path="copletData/attributes/uri" value="cocoon:/coplets/xsp/the_other_file.xsp"/>
<!-- content reloading-->
                      <cl:content>My Link Content</cl:content>
        </p>
</cl:links> 
............................................
************************************

What I should write in the  the_other_file.xsp file to get the id parameter value?????

************************************
The other xsp file
************************************
????????????????????????
???????????????????????
************************************

Thanks for help 
Mario



Mime
View raw message