cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <tcu...@vafer.org>
Subject Re: XML Parsing Error: no element found
Date Mon, 22 Mar 2004 11:25:50 GMT
beyaNet Consultancy wrote:
> hi,
> I am getting the above error message when I try and run the following 
> xsp page. Can I do this? If not how do I??
> 
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <xsp:page language="java"
> xmlns:xsp="http://apache.org/xsp"
> xmlns:util="http://apache.org/xsp/util/2.0"
> xmlns:xlink="http://www.w3.org/1999/xlink"
> xmlns="http://www.w3.org/2000/svg">
> 
> <xsp:structure>
> 
> <xsp:include>test.ArtistImages</xsp:include>
> </xsp:structure>
> 
> <xsp:element name="svg">

Why do you do that?

You could just use a <svg/> tag instead.

> <map:match pattern="**artistImage/*/*/*/*.jpg">
> <map:generate type="serverpages" src="xsp/svg.xsp">

Check the XML which comes out here.
E.g. serialize as plain xml first.
Does it look like you'd exspect it?

> <map:parameter name="imageNum" value="{5}"/>
> <map:parameter name="artistID" value="{2}"/>
> <map:parameter name="svgWidth" value="{3}"/>
> <map:parameter name="svgHeight" value="{4}"/>
> </map:generate>
> <map:serialize type="svg2jpeg"/>
> </map:match>

cheers
--
Torsten



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message