cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans ...@domek.be>
Subject Re: Strange output from aggregator (bug?)
Date Mon, 01 Mar 2004 08:48:46 GMT
Are you in a position to quickly test this against 2.1.4 ? If not post 
your a.xml file so we can test this.


Thanks
Jorg
David Leangen wrote:
> Hi!
> 
> 
>>It's probably embedded as a quote if you're using mozilla
>>so more like
>>
>><r>
>>
>>">"<a>
>>
>>asdf
>></a></r>
>>
>>Note the quotes around the ">"
> 
> 
> When I look at the XML source (using View-->Page Source), there don't seem
> to be any quotes.
> 
> Also, what's interesting is that when I use namespaces, I get something like
> the following:
> 
> <ac:aggregated-content>
>  xmlns:ac="http://konova.com/ns/expedition-aggregated-content">
> ...
> </ac:aggregated-content>
> 
> Note that the attribute of the root tag is after the ">", but itself has its
> own closing ">".
> 
> 
> I tried this in IE, and got the following error:
> 
> ******************
> 
> The XML page cannot be displayed
> Cannot view XML input using XSL style sheet. Please correct the error and
> then click the Refresh button, or try again later.
> 
> 
> ------------------------------------------------
> 
> Reference to undeclared namespace prefix: 'ac'. Error processing resource
> 'http://localhost:8888/ns/test'. Line 2, Position 24
> 
> <ac:aggregated-content>
> 
> ******************
> 
> This error makes sense only if the extra ">" is being output.
> 
> 
> 
>>@David: which version are you using?
> 
> 
> 2.1.3
> 
> 
> I'm ok with this, since the problem magically goes away with the use of any
> transformer or a serializer other than XML. However, I thought that someone
> would like to know.
> 
> 
> Regards,
> David


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message