cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Painter-Wakefield <paint...@mc.duke.edu>
Subject Re: Re[2]: Very strange IE problem
Date Wed, 03 Mar 2004 17:25:11 GMT




I don't know if this is related, but we have a similar problem with a page
that generates PDFs.  The generation take a while, so we have a "please
wait" page that displays and does a refresh to get the generated page when
it is ready.  IE won't open the PDF, and gives a strange error message.
This definitely only started happening recently (last six months, maybe?),
and we believe it is due to some security patch or other.  However,
changing the security settings for IE to the most permissive doesn't fix
the problem.  If we don't use the refresh page, the problem goes away.

If anyone finds a workaround involving some change to IE settings or
whatever, please share it!

-Christopher



|---------+---------------------------->
|         |           "Johnson"        |
|         |           <johnson@soho.clu|
|         |           b.tw>            |
|         |                            |
|         |           03/03/2004 12:12 |
|         |           PM               |
|         |           Please respond to|
|         |           users            |
|         |                            |
|---------+---------------------------->
  >--------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                       |
  |       To:       <users@cocoon.apache.org>, "Andrey Almirov" <almirov@inbox.ru>
                              |
  |       cc:                                                                            
                       |
  |       Subject:  Re: Re[2]: Very strange IE problem                                   
                       |
  >--------------------------------------------------------------------------------------------------------------|




Take a break,I think it probably security probelm for ie6
because of MS system open several property by default,like active-x...,so
it
is easy attacked by virus hacker..
so from ie6 and oe6,MS close lots of unsafety feature,users must open it by
themselves.
so pls try to set the safety of ie6 to lowest,and open all feature closed
by
dedault,then try again.
goodwiil

Johnson


----- Original Message -----
From: "Andrey Almirov" <almirov@inbox.ru>
To: "Carmona Perez, David" <users@cocoon.apache.org>
Sent: Thursday, March 04, 2004 12:55 AM
Subject: Re[2]: Very strange IE problem


> Hello Dear Cocoon users!
>
> CPD> Why don't you search in msdn.microsoft.com for IE bugs?
> So, I found that it is some Microsoft's IE bug.
>
> BUT. I can not say to my customers  that it is Microsoft bug. And
> Microsoft have not patch for it yet.
>
> So I need to cure this problem somehow.
>
> We not some strange details, that say us that it is not pure IE
> problem.
>
> 1. This error appears only when we have redirect to the pipeline.
> 2. We have this error even we redirect from some servlet (not Cocoon
> system).
> 3. I saved the page which Cocoon generate (big page which leads to
> IE error) as usual html page. And redirected to it. All works fine.
>
> >From 3. I concluded that this is Cocoon - IE strange not compatibility
>
> Does  somebody have some ideas?
>
> Thanks in advance!
>
> CPD> --------
> CPD> David
>
> CPD> -----Mensaje original-----
> CPD> De: Andrey Almirov [mailto:almirov@inbox.ru]
> CPD> Enviado el: jueves, 26 de febrero de 2004 17:21
> CPD> Para: users@cocoon.apache.org
> CPD> Asunto: Very strange IE problem
>
> CPD> Hello, dear Cocoon users!
>
> CPD> I have 2 pipelines: A and B
>
> CPD> A pipeline:
>
> CPD> <map:match pattern="*">
> CPD>   <map:select type="parameter">
> CPD>     <map:parameter name="parameter-selector-test"
> CPD> value="{request-param:command}"/>
> CPD>     <map:when test="go">
> CPD>       <map:redirect-to uri="cocoon:/bigPage"/>
> CPD>     </map:when>
> CPD>     <map:otherwise>
> CPD>       <map:generate src="xml/startPage.xml"/>
> CPD>       <map:serialize type="html"/>
> CPD>     </map:otherwise>
> CPD>   </map:select>
> CPD> </map:match>
>
> CPD> When I visit  A  it just shows some button. When I click on
> CPD> this button pipeline redirects to B.
>
> CPD> B is usial pipeline
>
> CPD> <map:match pattern="bigPage">
> CPD>   <map:generate src="xml/bigPage.xml"/>
> CPD>   <map:serialize type="html"/>
> CPD> </map:match>
>
> CPD> where bigPage.xml *MUST* have the following properties:
> CPD> 1. It musts have a big size.
> CPD> 2. It musts load some css or script.
>
> CPD> The problem is that when A redirect to B sometime the error
> CPD> "InternetExplorer cannot open the site
> CPD> ... Operation aborted"
>
> CPD> Or just white screen appears.
>
> CPD> It happens on IE 6 only.
>
> CPD> Configuration: Windows Professional 2000, Tomcat 4.1.24, Cocoon
2.1.4
>
> CPD> In attachment there are all needed files.
>
> CPD> In the experiments I have noted that this effect depends on
> CPD> size of file, and on Inet speed. So I do
> CPD> this experiment in localhost (Inet speed rather big)
>
> CPD> Thanks in advance.
>
> CPD> Andrey
>
> CPD>
---------------------------------------------------------------------
> CPD> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> CPD> For additional commands, e-mail: users-help@cocoon.apache.org
>
>
>
>
> --
> Best regards,
>  Andrey                            mailto:almirov@inbox.ru
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message