cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lundquist ...@wrinkledog.com>
Subject Re: Woody cannot find its FormManager
Date Wed, 24 Mar 2004 18:05:40 GMT

On Mar 24, 2004, at 6:00 AM, Peter Lerche wrote:

> Hi,
>
> I am trying to "upgrade" from jxForm to Woody on a 2.1.4 dest.  
> installation.
> For some reason the class org.apache.cocoon.woody.FormManager cannot  
> be found
> when a pipeline calls this minimal flow js scripts
>
> function test(){
> 	var form = new Form("/woodyform.def");  // Yak! where is my  
> FormManager
> 	form.showForm('/woodypage.wf');
> }
>
> I have tried to use
> cocoon.load("resource://org/apache/cocoon/woody/flow/javascript/v2/ 
> Form.js");
> and
> cocoon.load("resource://org/apache/cocoon/woody/flow/javascript/ 
> woody2.js");
> with the same result.
>
> I have checked that cocoon-woody-block.jar contains the
> org.apache.cocoon.woody.FormManager and it does.
>

OK, does your cocoon.xconf contain a <woody-formmanager> element?  If  
not, have a look at the cocoon.xconf from a 2.1.4 build where the woody  
block was enabled.  Actually, if your cocoon.xconf is missing this,  
you'd better diff it against one from the build,  'cause you'll also be  
missing a slew of other Woody stuff, and who knows what else.

Also, just a tip... never mix flowscripts that load woody2.js in the  
sitemap w/ flowscripts that load v2/Form.js — bad things happen :-/.

HTH,
~ mark



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message