cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Q: install Cocoon 2.0.4-vm14 binary on Tomcat 5.0.19?
Date Fri, 05 Mar 2004 22:37:04 GMT
On 05.03.2004 21:57, czheng@commira.com wrote:

> I've followed INSTALL file  in  cocoon-2.0.4-vm14-bin.zip (since it's the 
> most recent downloadable binary from Apache)  to isntall it on latest 
> Tomcat 5.0.19.  And found following error in stderr.  the Install html 
> page only tells how to install on up to Tomcat 4.0.4b.  Has any one had 
> luck with this pair?

Unfortunately we have delivered Cocoon 2.0.4 with a broken batik JAR - 
that's the error message you get. If you replace it by hand the 
deployment will work. The error is fixed in 2.0 CVS, just download the 
batik-all-1.5.jar from 
http://cvs.apache.org/viewcvs.cgi/cocoon-2.0/lib/optional/.

But when doing this I guess you can also grab the 2.1.4 sources and 
build Cocoon yourself. Don't fear, it's really easy. There is an INSTALL 
file in the root that describes how to do it. If you use the standard 
config it's just a "build war" (for deployment in Tomcat) or a "build" 
and a "cocoon servlet" afterwards for having Jetty running with Cocoon.

Joerg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message