cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Winnall <st...@winnall.ch>
Subject Re: Problem with xinclude...
Date Wed, 10 Mar 2004 23:03:12 GMT
I tried to work around it by using XSLT's document() function, but I'm  
going to have
have to come back and try it again - probably sometime next week. I'll  
let you know
then what happens.

Thanks
Steve

On 10 Mar 2004, at 21:39, Joerg Heinicke wrote:

> On 13.02.2004 09:57, Stephen Winnall wrote:
>
>> Everything works OK if I comment out the xinclude transformation in  
>> the  pipeline. The generated
>> xinclude tag looks like this when I try to generate the target   
>> addresses.html:
>> <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"   
>> href="cocoon:/addresses.xhtml" />
>> But when the xinclude transformation is included, I get the following  
>>  error:
>>     Failed to execute pipeline.
>>     org.apache.cocoon.ProcessingException: Failed to execute  
>> pipeline.:
>>     java.lang.RuntimeException: java.lang.NullPointerException
>
>> java.lang.RuntimeException: java.lang.NullPointerException
>>         at   
>> org.apache.xalan.transformer.TransformerImpl.run(TransformerImpl.java: 
>>  3363)
>
> Did you solved it? Otherwise try the environment check and see if the  
> expected version of Xalan is in use:
> http://xml.apache.org/xalan-j/faq.html#environmentcheck.
>
> Joerg
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message