cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joel Sookram" <j...@firstcitizenstt.com>
Subject RE: Problems Loading Generator Component
Date Mon, 08 Mar 2004 16:32:19 GMT
Thanks for your response.

I'm using the Jetty server provided with Cocoon 2.1.3. I did restart the
server several times but I keep getting the same error. I know this could be
a deployment problem but it is quite stubborn. Is there a location besides
the 'build\webapp\WEB-INF\lib\'directory for deploying new or customized
classes?

Thanks,
Joel

-----Original Message-----
From: Hildebrandt, Ole [mailto:ole.hildebrandt@eds.com]
Sent: Monday, March 08, 2004 10:16 AM
To: users@cocoon.apache.org
Subject: AW: Problems Loading Generator Component


Hi,

>From the stacktrace I would say that Cocoon was unable to load your
Registration-Class. (NoClassDefFound)
Make sure, that you have deployed it properly. Have you restarted TomCat?

Ole

> -----Ursprüngliche Nachricht-----
> Von: Joel Sookram [mailto:joel@firstcitizenstt.com]
> Gesendet: Montag, 8. März 2004 15:03
> An: users@cocoon.apache.org
> Betreff: Problems Loading Generator Component
>
>
> Hello everyone,
>
>  I' m currently working on a school project in which I'm
> trying to develop a web site with news portals. I had
> modified the class ConfigurationGenerator and called it
> 'Registration' to  allow users to register themselves before
> logging in to the portal web site. After I had compile the
> modified class, I had added it to
> 'cocoon-authentication-fw-block.jar' in  WEB-INF/lib
> directory. The main sitemap was updated as  '<map:generator
> label="content" name="reg-conf"
> src="org.apache.cocoon.webapps.authentication.generation.Regis
> tration"/>'
> under the components section. When I fired up the cocoon
> servlet I got the following message:
>
> Internal Server Error
> Message: null
>
> Description: No details available.
>
> Sender: org.apache.cocoon.servlet.CocoonServlet
>
> Source: Cocoon Servlet
>
> Request URI
>
> FCB1.2/
>
> cause
>
> org.apache.cocoon.webapps.authentication.generation.Registration
>
> request-uri
>
> /FCB1.2/
>
> Apache Cocoon 2.1rc1
>
>
>
> Attached is the error log. I have tried many approaches to
> solve this problem but nothing seems to work. Could someone
> give me some hints as to what I am doing wrong? I am fairly
> new to Cocoon and I am currently using Cocoon 2.1.3.
>
>
> Thanks,
> Joel
>
>
>
> ----------------------------------------------------------
> The information contained in this e-mail transmission is
> confidential and may be privileged. If you are not the
> intended recipient you are hereby notified that any use,
> dissemination or reproduction of this transmission (including
> any attachments) is strictly prohibited. If you have received
> this e-mail in error, please notify the sender immediately by
> e-mail reply and then delete it from your system.
> ----------------------------------------------------------
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org

----------------------------------------------------------
The information contained in this e-mail transmission is confidential and may be privileged.
If you are not the intended recipient you are hereby notified that any use, dissemination
or reproduction of this transmission (including any attachments) is strictly prohibited. If
you have received this e-mail in error, please notify the sender immediately by e-mail reply
and then delete it from your system.
----------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message