cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Burkard <sburk...@previon.ch>
Subject woody/flowscript and URI-problem
Date Sun, 15 Feb 2004 17:22:16 GMT
hi there

i've got a problem with the combination of woody/flowscript and URIs. i 
followed the registration-example in the cocoon-wiki that uses woody and 
flowscript. that runs perfectly.

as i changed this example step by step to my needs, i arrived with this 
problem:
i'm putting the locale for i18n in the URI of all requests, for example 
"/en/woodyform.xml" that runs also fine to build the form.

but when i submit the form i use the construct 
"#{$continuation/id}.continue" as the form-action. the complete request 
  is then "en/[id].continue" and i have a sitemap-entry that matches 
this post with "*/*.continue" and i pass the pure id with <map:call 
continuation="{2}"/> but this ends with the error "Resource Not Found".

to test that the sitemap really calls this code, i changed the value of 
the continuation like this <map:call continuation="{1}/{2}"/> and i get 
- correctly - an error, so it runs the correct code in the sitemap

finally my question: isn't it possible to submit the continuation-id 
with any other information in the URI? if i switch back all my files to 
a URI without locale everythings ok again!

thanks and greetings
stefan



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message