cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DA...@Nationwide.com
Subject Re: XSP Validation XSP-formval
Date Thu, 19 Feb 2004 20:35:53 GMT
Hi Anna,

The spaces may be appearing because you have put spaces and newlines in 
the following:

 <input name="enddate" type="text" >
 <xsp:attribute name="value">
  <xsp-request:get-parameter name="enddate" default=""/>
 </xsp:attribute>
 </input>

To eliminate them, try reformatting and condensing what you have to:

 <input name="enddate" type="text" >
   <xsp:attribute name="value"><xsp-request:get-parameter name="enddate" 
default=""/></xsp:attribute>
 </input>

Not 100% sure it'll fix your problem, but I've often has spaces crop up 
when trying to adhere to a "nice" format, and they usually disappear when 
I condense the XML.

HTH!

Thanks!
David Day




Anna Bikkina <anna@pinksheets.com>




02/19/2004 03:26 PM
Please respond to users

 
T
To:     users@cocoon.apache.org
cc: 

bcc: 
Subject:        Re: XSP Validation XSP-formval


Never mind that worked. I am now able to validate my form. The problem is 
with 
sitemap . The descriptor file could not be located. When I changed the 
path 
it worked.

One other question. To refill the values in the form when there is some 
problem in the input. I am using the tags
 <input name="enddate" type="text" >
 <xsp:attribute name="value">
  <xsp-request:get-parameter name="enddate" default=""/>
 </xsp:attribute>
 </input>

Everytime I click submit and the same page is reloaded due to some errors 
I 
see a couple of spaces added to the input text value at the beginning. The 

length of the text value is increasing. Did anyone see similar problem. 
Any 
help will be appreciated. How can I get rid of the spaces in front of my 
input text which are being created when I click on submit.

Thanks in advance,
Anna.



On Thursday 19 February 2004 02:50 pm, Anna Bikkina wrote:
> Hi,
>
> I am using xsp-formval to validate data in my xsp forms. Somehow I am 
not
> able to validate the form . My XSP form has the following lines
>
> <xsp-formval:descriptor
> name="/usr/local/jboss/tomcat/webapps/cocoon/myserver/
> styles/descriptor.xml" constraint-set="securityquote">
>                                                <paragraph>
> <xsp-formval:results/>
>                                                </paragraph>
>
> and so on...
>
> I have my descriptor file in the same location. Here is my descriptor 
file.
>
> <?xml version="1.0" encoding="UTF-8"?>
> <root>
>
>    <parameter name="security" type="string" min-len="2" max-len="15"
> nullable="no"/>
>    <parameter name="startdate" type="string" nullable="no" min-len="6"
> max-len="10"/>
>     <parameter name="enddate" type="string" nullable="no" min-len="6"
> max-len="10"/>
>
>    <constraint-set name="securityquote">
>        <validate name="security"/>
>        <validate name="startdate"/>
>        <validate name="enddate"/>
>     </constraint-set>
>
> </root>
>
>
> For some reason no valdiation is being done. I am checking not null 
fields
> and even when I give all non null fields its not raising an error. Is 
there
> something that I am missing here. Please comment.
>
> Thanks in advance,
> Anna.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message