cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: cocoon with j2sdk 1.5b?
Date Tue, 17 Feb 2004 00:55:09 GMT
This is correct your current version was compiled for 1.4 and since 1.5 is
still Beta maybe there are some issues.

The problems with compiling are related to the VM checking inside Cocoon.
I think if you want to build a test You will need to change some files in
cocoon-2.1/tools/targets dir. See: init-build.xml on line 16:

<!-- Detecting the current jvm -->
    <condition property="target.vm" value="1.4">
      <equals arg1="1.4" arg2="${ant.java.version}"/>
    </condition>
    <condition property="target.vm" value="1.3">
      <not>
        <equals arg1="1.4" arg2="${ant.java.version}"/>
      </not>
    </condition>

And changes this code to work with 1.5

AFAIK one of the improvements in Ant 1.6.1 (currently in Cocoon 2.1.5-dev
CVS) is that can work with 1.5. Almost this is said in the release notes
:-D

Hope this would help and plase comment about your archievements ;-)

Best Regards,

Antonio Gallardo

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message