cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: building Collection from JDO problems
Date Sat, 21 Feb 2004 13:29:18 GMT
Bert Van Kets dijo:
>> Are you jaring the DAO classes?
> No, just compiling them in the classes folder in the right package
> directory. I tried to jar them at first, but then none of them were found.

This is weird! How jaring is not avaliable. In my devel environment I use
eclipse + ant to build a jar with my DAO classes that is then copied to
WEB-INF/lib directory of my Cocoon app. After this I need to reboot
tomcat.

This way I did it hundreds if not thousands of times while developing my
current work.

Are you tried to investigate why your classes packaged in a jar are not
seeing by Cocoon. I think this is the root of the problem.

>>Are the classes visibles at all?
> Aparently not in the Cocoon package.
> I did a print(dao) in the flowscript and it returns "undefind"
> Your system, writing to the log, has the same message. Printing to the
> console is a little easier int his case as I don't have to shut down
> Tomcat
> to open the log file. Freaking MS. :-(

No problem :-D

>
>
>> To help me know if this variable is empty or not.
> Aparently it not. :-(

Yes. It is empty, because you got "undefined" that means the variable
don't got any value.

Can you send again the javascript code? Please don't snip, because the
problem can be related where you define the variable and where you use it.

This is why I prefer to write the code in Java and not in Javascript. I
will be glad to have a similar IDE as eclipse for Javascript. ;-)

Best Regards,

Antonio Gallardo

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message