cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anna Bikkina <a...@pinksheets.com>
Subject XSP Validation XSP-formval
Date Thu, 19 Feb 2004 19:50:08 GMT
Hi,

I am using xsp-formval to validate data in my xsp forms. Somehow I am not able 
to validate the form . My XSP form has the following lines

<xsp-formval:descriptor name="/usr/local/jboss/tomcat/webapps/cocoon/myserver/
styles/descriptor.xml" constraint-set="securityquote">
			<paragraph>
				<xsp-formval:results/>
			</paragraph>

and so on... 

I have my descriptor file in the same location. Here is my descriptor file.

<?xml version="1.0" encoding="UTF-8"?>
<root>

   <parameter name="security" type="string" min-len="2" max-len="15"  
nullable="no"/>
   <parameter name="startdate" type="string" nullable="no" min-len="6" 
max-len="10"/>
    <parameter name="enddate" type="string" nullable="no" min-len="6" 
max-len="10"/>

   <constraint-set name="securityquote">
       <validate name="security"/>
       <validate name="startdate"/>
       <validate name="enddate"/>
    </constraint-set>

</root>


For some reason no valdiation is being done. I am checking not null fields and 
even when I give all non null fields its not raising an error. Is there 
something that I am missing here. Please comment.

Thanks in advance,
Anna.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message