cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Almirov <almi...@inbox.ru>
Subject Very strange IE problem
Date Thu, 26 Feb 2004 16:21:02 GMT
Hello, dear Cocoon users!

I have 2 pipelines: A and B

A pipeline:

<map:match pattern="*">
  <map:select type="parameter">
    <map:parameter name="parameter-selector-test" value="{request-param:command}"/>
    <map:when test="go">
      <map:redirect-to uri="cocoon:/bigPage"/>
    </map:when>
    <map:otherwise>
      <map:generate src="xml/startPage.xml"/>
      <map:serialize type="html"/>
    </map:otherwise>
  </map:select>
</map:match>

When I visit  A  it just shows some button. When I click on this button pipeline redirects
to B.

B is usial pipeline 

<map:match pattern="bigPage">
  <map:generate src="xml/bigPage.xml"/>
  <map:serialize type="html"/>
</map:match>

where bigPage.xml *MUST* have the following properties:
1. It musts have a big size.
2. It musts load some css or script.

The problem is that when A redirect to B sometime the error  "InternetExplorer cannot open
the site
... Operation aborted" 

Or just white screen appears.

It happens on IE 6 only.

Configuration: Windows Professional 2000, Tomcat 4.1.24, Cocoon 2.1.4

In attachment there are all needed files.

In the experiments I have noted that this effect depends on size of file, and on Inet speed.
So I do
this experiment in localhost (Inet speed rather big)

Thanks in advance.

Andrey

Mime
View raw message