cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lionel Crine <cr...@4dconcept.fr>
Subject [entities] Problem
Date Thu, 08 Jan 2004 13:45:18 GMT
Hi,

You're my last chance to find my problem.

I have an XML document which contains some XML entities (&quot, &gt, etc ).
According to the element the entities are, the document is well or badly 
parsed. I'm not talking about entities into attributes but only into elements.

All the elements wich may contain this entities are #PCDATA.

Here is the parser method :

DocumentBuilder db = null;
db = DocumentBuilderFactory.newInstance().newDocumentBuilder();
myDocument = db.parse(stream);


If I write : <element>&quot;</element> (Ultraedit)
[Fatal Error] :1:644: Element type "module" must be followed by either 
attribute specifications, ">" or "/>".

The crazy thing is that the document is well displayed in IE or mozilla AND 
there are other &quot; in other elements of the document which don't crash 
the parser.

If I write <element>&amp;quot;</element>(Ultraedit)

The parser is OK. But IE and mozilla displayed  <element>&quot;</element>.



By the way, this problem is only happening in a transformer. I don't know 
if this is related.
This transformer gets the document from an XMLDB, convert it into a DOM and 
is returned into the flow.


Please what's happening ?

Lionel










Lionel CRINE
Ingénieur Systèmes documentaires
Société : 4DConcept
22 rue Etienne de Jouy 78353 JOUY EN JOSAS
Tel : 01.34.58.70.70 Fax : 01.39.58.70.70


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message