cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: WrappedRuntimeException
Date Mon, 12 Jan 2004 21:52:15 GMT
On 12.01.2004 12:01, gounis@osmosis.gr wrote:

> hi people 
> 
> after a system update i can not run cocoon.204 on tomcat 4.1.24
> 
> id dont have make any change in my .xml files or my sitemaps but i get the 
> follow error:
> 
> type fatal
> 
> message Failed to execute pipeline.
> 
> description org.apache.cocoon.ProcessingException: Failed to execute 
> pipeline.: org.apache.xml.utils.WrappedRuntimeException: The output format 
> must have a '{http://xml.apache.org/xalan}content-handler' property!
> 
> 
> the only new in my new setup is java from 1.4.1_01 to 1.4.2_03

In this case it's definitely the endorsed libs problem. The reason is 
the change of the Xalan version in the JDK from Xalan 2.2.D11 to 2.4. If 
you had never problems with the endorsed libs when using JDK 1.4, then 
it was luck - Jorg also had such a case. Maybe Xalan 2.4 is now 
incompatible to Cocoon 2.0.4's Xalan 2.3.1.

The solution is to put the three x*.jar (Xerces, Xalan, XML APIs) into 
Tomcat's common/endorsed directory.

Joerg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message