cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thorsten schmid <tsch...@novocron.de>
Subject empty page when using xsltc
Date Wed, 28 Jan 2004 18:30:02 GMT
Hello everyone,

My System:
Cocoon: cocoon 2.1.3
jdk: Sun 1.4.1_02
Servlet engine: Tomcat 4.1.18 (binary distribution)


My Problem: 
xsltc produces an empty output when cocoon runs as servlet within tomcat. 
Cocoon was compiled as a ".war" file by calling "build.sh war". 
The problem  doesn't occur as I run cocoon within jetty by calling "cocoon.sh 
servlet" in my COCOON_HOME directory.
I also doubt that using the binary version of tomcat might the reason for the 
problem, because the applikation worked fine with cocoon2.1-dev.

Sitemap snippets:
        .
        .
        .
<map:transformer logger="sitemap.transformer.xsltc" name="xsltc" pool-grow="2" 
pool-max="32" pool-min="8"  
src="org.apache.cocoon.transformation.TraxTransformer">
      <use-request-parameters>false</use-request-parameters>
      <use-session-parameters>false</use-session-parameters>
      <use-cookie-parameters>false</use-cookie-parameters>
      <xslt-processor-role>xsltc</xslt-processor-role>
      <check-includes>true</check-includes>
</map:transformer>
        .
        .
        .
        .
        .
        .
<map:match pattern="sitemap.html">
              <map:generate type="xalan" src="xml/sitemap.xml"/>
              <map:transform type="xsltc" src="xsl/sitemap2html.xsl"/>
              <map:serialize/>
</map:match>
        .
        .
        .

Does anyone have a clue what the reason could be?
best regards,

Thorsten


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message