cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Hoskens" ...@schaubroeck.be>
Subject REPOST Re: XSP Action, Bug?
Date Wed, 21 Jan 2004 15:05:30 GMT
I did another update (cocoon 2.1 cvs head) today, but still I get an error if I use an xsp
action in the following setup:

<map:match...>
    <map:act type="serverpages" src="actions/myaction.xsp">

        <map:call function="package">
            <!--some parameters, yes I did change my {1} to {../1} when I use the action,
if I leave the action out I use {1} and then it works-->
        </map:call>
    </map:act>
    ...<!--doesn't get here-->
</map:match>

I did use the same setup under the Cocoon Release 2.1.3 version and there it did work fine!

I now get another error, not referencing the serverpagesgenerator anymore but the pipeline
itself

 [sitemap.handled-errors] (/cocoon/cocoontest/blabla.html) http8080-Processor2/PipelineNode:
Failed to execute pipeline.
org.apache.cocoon.ProcessingException: Failed to execute pipeline.: java.lang.NullPointerException
 at org.apache.cocoon.components.pipeline.AbstractProcessingPipeline.processXMLPipeline(AbstractProcessingPipeline.java:564)

Anything broken? Any others that get the same error with xsp actions?

Greetings,

Jan
  ----- Original Message ----- 
  From: Jan Hoskens 
  To: users@cocoon.apache.org 
  Sent: Tuesday, January 20, 2004 10:24 AM
  Subject: XSP Action


  Hi,

  I've updated my cvs head today and tried to run my site. Whenever I want to use an xsp action,
I get a nullpointer exception:

  ERROR   (2004-01-20) 10:17.08:730   [sitemap.handled-errors] (/cocoon/cocoontest/index.html)
http8080-Processor2/PipelineNode: 
  java.lang.NullPointerException
   at org.apache.cocoon.generation.ServerPagesGenerator.setup(ServerPagesGenerator.java:198)
   at org.apache.cocoon.acting.ServerPagesAction.act(ServerPagesAction.java:169)

  My actions DID WORK in the release version 2.1.3!

  Is there anything broken in the current cvs head version ?

  Thanks,

  Jan
Mime
View raw message