cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Portier <...@outerthought.org>
Subject Re: Problem getting woody to properly build a selection widget
Date Tue, 30 Dec 2003 11:40:36 GMT


H.vanderLinden@MI.unimaas.nl wrote:

> Hi,
> 
> I'm trying to implement a simple form (no validation yet) which has one
> selection list widget (gender: values Female, Male, Unknown). I want to have
> this displayed as radiobuttons, but it fails to do so.
> 
> I've copy/paste/modify the form1 example but the selection list is not
> copied into the resulting wi:  xml.
> 
> I then added the sitemap pipelines and .js script from the original form1
> example, modified the source location to use the original files and it still
> works.
> 

hoeray!
(I take it you forgot the negation in that last sentence :-))

> I don't get any errors and the script can find the definition file, because
> all labels and hints are correctly copied.
> 
> The only thing I can think of is the value of the "attribute-name"
> parameter:
> 
>      <map:match pattern="form1.flow">
>        <map:call function="woody">
>          <map:parameter name="function" value="form1"/>
>          <map:parameter name="form-definition"
> value="context:://samples/woody/forms/form1.xml"/>
>          <map:parameter name="attribute-name" value="form1"/>   <-- which
> "form1" does this one refer to?

I've tracked when this parameter was removed from the flowscript:
http://cvs.apache.org/viewcvs.cgi/cocoon-2.1/src/blocks/woody/java/org/apache/cocoon/woody/flow/javascript/woody.js?r1=1.5&r2=1.6&diff_format=h

this was even pre release-candidate for 2.1, this means that having it 
there doesn't make a difference at all. (unless you would still be 
working on that odd cvs-snapshot from back then)

However, I did notice that while flow ignores it our sample sitemap.xmap 
is still mentioning it today (that is fixed now on 2.1 cvs-head)

bottom line: thx for making me look and fix, but this should not be the 
reason for your issues...

looking into those, I can't find an explanation based on the provided 
info, maybe you can send some more detail of your setup?


regards,
-marc=
-- 
Marc Portier                            http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
Read my weblog at                http://blogs.cocoondev.org/mpo/
mpo@outerthought.org                              mpo@apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message