cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: stability of CVS version (was: Set attribute to session in fl owscript (more infos...)?)
Date Mon, 29 Dec 2003 12:38:22 GMT
H.vanderLinden@MI.unimaas.nl wrote:

> Hi,
> 
> I frequently read about "bug fixed/feature added in CVS version". I just
> wonder how "risky" it is to use the latest version in the CVS rather than
> 2.1.3?

If you set up a system for development which enables you to quickly 
upgrade versions, there is probably negligible risk associated with 
using the cvs version of a fairly mature branch like 2.1.  Since a 2.1 
official release has happened (now several times), you should be able to 
assume that: no major new functionality will be introduced, no backwards 
  incompatible changes will be introduced, and nothing will become 
broken (or the breaking changes would be reverted pretty quickly).

There are past posts and info on the wiki with some best practice 
suggestions for how to set up a development environment which lets you 
change cocoon versions relatively painlessly.

Geoff


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message