cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: upgraded to cocoon 2.1 and fop is not working
Date Wed, 24 Dec 2003 01:54:51 GMT
2 possible problems I see:

1. endorsed libs: You -Djava.endorsed.dirs is empty, so you use the JDK 
XML libs. This is not "that" bad (but still not recommended) with 1.4.2 
as it includes Xalan 2.4 AFAIK. But it's another version than included 
with Cocoon. You should set the parameter to lib/endorsed of Cocoon 
sources (including Cocoon's XML libs) as it is done in the Jetty script.

2. FOP depends on Batik and the Batik version delivered with Cocoon is 
another one delivered in the FOP dist. Maybe a reason, but I don't know 
that well.

Joerg

On 04.12.2003 12:18, Joose Vettenranta wrote:

> Hey,
> 
> I upgraded to cocoon 2.1.2  and FOP stoped working. According to the 
> logs, page is rendered, but nothing is sent to browser. I am trying to 
> use fop-sample which came with cocoon.
> 
> First I tried with java 1.4.1 but it didn't work (worked with cocoon 
> 2.0.3) and now using 1.4.2_02 java.
> 
> I have checked that it outputs nothing with Safari and Lynx.
> 
> I am using DEBUG as debug level.
> 
> Nothing interesting in tomcat logs (using debug="1")
> 
> ps output:
> /usr/java/j2sdk1.4.2_02/bin/java -server -Xmx1536m -Xincgc 
> -Djava.awt.headless=true -Djava.endorsed.dirs= -classpath 
> /usr/java/j2sdk1.4.2_02/lib/tools.jar:/var/tomcat4/bin/bootstrap.jar 
> -Dcatalina.base=/var/tomcat4 -Dcatalina.home=/var/tomcat4 
> -Djava.io.tmpdir=/var/tomcat4/temp org.apache.cat



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message