cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Coboos <cromo...@gmx.net>
Subject autosave-uploads doesn't work?
Date Tue, 23 Dec 2003 09:04:40 GMT
Hello,

I need to upload a file. Therefore I have read the documentations on the 
wiki. Uploading files looks thery simple, but doesn't work on my system. 
I want to auto upload the file into the folder 
$CATALINA_HOME/cocoon/media/images, so I have changed the following 
entries in the web.xml:

    <init-param>
      <param-name>upload-directory</param-name>
      <param-value>media/images</param-value>
    </init-param>

    <init-param>
      <param-name>autosave-uploads</param-name>
      <param-value>true</param-value>
    </init-param>

My form looks like the following:

   <form action="upload" method="POST" enctype="multipart/form-data">
      <input type="file" name="picture"/>
      <input type="submit" value="Upload now"/>
   </form>

After pressing "Upload now" the file should be placed into media/images, 
I'm right? But nothing is placed on this directory. Why?

I'am using a flowscript to validate some input datas and I don't want to 
"write out" the InputStream, but this works fine. I'am receiving the 
Part-Object an then I'am able to "write down" the stream to disk but I 
dont want this. But why autosave-uploads doesn't work?

Thank you!


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message