cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sarah Haff <sarah_h...@yahoo.com>
Subject Re: AW: testing cache
Date Fri, 19 Dec 2003 22:45:53 GMT
Marco,

Here is the sitemap.xmap (i have also attached it with
this email.
----
<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- CVS $Id: sitemap.xmap,v 1.16 2003/10/22 11:42:05
joerg Exp $ --><map:sitemap
xmlns:map="http://apache.org/cocoon/sitemap/1.0">

<!-- =========================== Components
================================ -->

 <map:components>




<map:transformers> 

<!-- other map:transformers here --> 
<!-- Xalan transformer (no xslt-processor-role) --> 
<map:transformer name="xslt-xalan" pool-grow="2"
pool-max="32" pool-min="8"
src="org.apache.cocoon.transformation.TraxTransformer">

<use-request-parameters>false</use-request-parameters>

<use-browser-capabilities-db>false</use-browser-capabilities-db>

</map:transformer> 

<!-- Saxon transformer look at the new element:
xslt-processor-role --> 
<map:transformer name="xslt-saxon" pool-grow="2"
pool-max="32" pool-min="8"
src="org.apache.cocoon.transformation.TraxTransformer">

<use-request-parameters>false</use-request-parameters>

<use-browser-capabilities-db>false</use-browser-capabilities-db>

<xslt-processor-role> 
org.apache.cocoon.components.xslt.XSLTProcessor/Saxon 
</xslt-processor-role> 
</map:transformer> 

<!-- other map:transformers here --> 

</map:transformers> 



  <map:readers default="resource"/>
<map:serializers default="html">

  <map:serializer name="html" mime-type="text/html;
charset=iso-8859-1"
    
src="org.apache.cocoon.serialization.HTMLSerializer">
    <encoding>iso-8859-1</encoding>
    <omit-xml-declaration>false</omit-xml-declaration>
  </map:serializer>
   
  <!-- other serializers -->
   
</map:serializers>

  <map:matchers default="wildcard">
     <map:matcher logger="sitemap.matcher.header"
name="filename"
src="org.apache.cocoon.matching.modular.CachingRegexpMatcher">
        <input-module name="request-param">
           <parameter>filename</parameter>
        </input-module>
     </map:matcher>
  </map:matchers>
  <map:selectors default="browser"/>
 </map:components>

<!-- =========================== Views
=================================== -->


<!-- =========================== Pipelines
================================= -->

 <map:pipelines>
  <map:pipeline type="caching">


	  <map:match pattern="index.html">
                <map:generate src="index.xml"/>
		<map:transform type="xalan"
src="/home/xsl/morphon2html.xsl">
			<map:parameter name="contextPath"
value="{request:contextPath}"/>
     		</map:transform>
                <map:serialize type="html"/>
            </map:match>



   <!-- ========================== Stream
================================= -->


   <!-- ========================= Other Samples
================================ -->


   <!-- ========================= Utilities
================================ -->


   <!-- ======================== Automount
=============================== -->
  </map:pipeline>
</map:pipelines>
</map:sitemap>
-------------------------------


--- Marco Rolappe <m_rolappe@web.de> wrote:
> hi sarah,
> 
> it doesn't to be exactly the line I mentioned, just
> something similar. but I
> if you don't get something like 'using valid cached
> content', then there's
> probably nothing cached.
> 
> whether something gets cached depends on the
> components used. e.g. if you
> generate from XSPs (and don't prepare them for being
> cacheable), the first
> step in your pipeline and thus the whole pipeline
> won't be cacheable.
> 
> you could create a test pipeline, with a 'file'
> generator and an 'xml'
> serializer. that whole pipeline is cacheable and
> that should be reflected in
> the logs.
> 
> you might want to provide a bit of info about the
> components used in your
> pipeline to see why it's not caching.
> 
> > -----Ursprungliche Nachricht-----
> > Von:
>
users-return-60158-m_rolappe=web.de@cocoon.apache.org
> >
>
[mailto:users-return-60158-m_rolappe=web.de@cocoon.apache.org]Im
> Auftrag
> > von Sarah Haff
> > Gesendet: Freitag, 19. Dezember 2003 22:40
> > An: users@cocoon.apache.org
> > Betreff: Re: AW: testing cache
> >
> >
> > > > first ensure that the debug level for category
> > > > 'sitemap' is set to DEBUG.
> >
> > ok I figured this out (in WEB-INF/logkit.xconf) .
> But
> > I still dont see the :
> > -----------------------
> > validatePipeline:
> > using valid cached content for ....
> > -----------------------
> >
> > Does that mean the caching is not working? I am
> using
> > Cocoon 2.1.3
> >
> > Thanks.
> > Sarah
> >
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail:
> users-help@cocoon.apache.org
> 

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree
Mime
View raw message