cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Painter-Wakefield <paint...@mc.duke.edu>
Subject Re: XSP/ESQL escaping
Date Tue, 04 Nov 2003 19:58:13 GMT




Where and how is formatMessage() implemented?  That is the code we really
need to see, I think.

We also use eclipse+tomcat 4+cocoon 2.0.x.  For some classes of error (I'm
not sure which ones), Eclipse suspends the thread for debugging, which
might be causing the timeout you are experiencing.  If you don't get a
response in the expected time, go to the debug perspective and continue and
suspended threads.  That will produce the normal Cocoon error message page
in your browser.  (There might be a way of telling eclipse to ignore those
exceptions, I haven't explored it.)

-Christopher



|---------+---------------------------->
|         |           Anders Forsgren  |
|         |           <anders@digitalfa|
|         |           rmers.com>       |
|         |                            |
|         |           11/04/2003 02:41 |
|         |           PM               |
|         |           Please respond to|
|         |           users            |
|         |                            |
|---------+---------------------------->
  >--------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                       |
  |       To:       users@cocoon.apache.org                                              
                       |
  |       cc:                                                                            
                       |
  |       Subject:  XSP/ESQL escaping                                                    
                       |
  >--------------------------------------------------------------------------------------------------------------|




Hi

I have a problem with escaping when retrieving database data in an xsp
page. For each row in the resultset, the following xml is generated:

<message>
   <subject><esql:get-string column="subject"/></subject>
   <author><esql:get-string column="author"/></author>
   <time><xsp:expr>formatDate(<esql:get-string
column="time"/>)</xsp:expr></time>
   <body><xsp:expr>formatMessage(<esql:get-xml
column="body"/>)</xsp:expr></body>
</message>

The formatMessage method will replace all line breaks (\n) with the tag
<br/>, however in this context that will give a  an error for some
reason. If I replace the \n's with &gt;br/&lt; etc, then it works, so
it's a document structure error obviously, but I don't see why it should
be?.

Also, which is the best way to develop xsp efficiently? I'm using
eclipse/tomcat4/cocoon2.0 on windows, and with this configuration the
requests time out when there is an error in either the code or structure
of the xsp, not easily debugged. Even the not-so-helpful generated code
error pages would be more helpful, but they only show up on rare occasions.

Thanks for any help

Anders



>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message