cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amaresh Wakkar <amaresh.wak...@uk.ibm.com>
Subject XSP pages being rendered without the text content in the text nodes!!! SOS
Date Fri, 28 Nov 2003 14:35:34 GMT
Hi Everyone,
I am using cocoon-2.1 on Win2000 with Websphere5 and WSAD(websphere studio 
5.0 using IBM Java 1.3.1 compatible VM).
Basically I am trying to get a simple XSP page working..
  
<?xml version="1.0"?>
<xsp:page language="java"
xmlns:xsp="http://apache.org/xsp"
xmlns:esql="http://apache.org/cocoon/SQL/v2"
>
<page>
<test>hello world..again..gdfgdfgdg</test>
<content>Willskfhsfsfsdf this be displayed???bcbcbcbcbcbc</content>
</page>
</xsp:page>
The sitemap entry is like this..
<map:match pattern="xsp/test.xsp">
<map:generate type="serverpages" src="xsp/test.xsp" /> 
<!--map:transform type="xslt" src="xsl/{1}.xsl" /-->
<map:serialize type="xml" />
</map:match> 

The result is as follows :
<?xml version="1.0" encoding="UTF-8" ?> 
- <page xmlns:xsp="http://apache.org/xsp" 
xmlns:xspdoc="http://apache.org/cocoon/XSPDoc/v1" 
xmlns:esql="http://apache.org/cocoon/SQL/v2">
  <test /> 
  <content /> 
  </page>
In short I am seeing all my elements without the text content in 
them..Please advise me if there is anything else that I need to get it 
working??
 
I have tried all possible permutations of XML parsers and XSLT 
transformers, still no joy..It is the same thing with cocoon samples..Does 
anyone know what is the reason?? Please help me...SOS!!
Mime
View raw message