cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ugo Cei <u....@cbim.it>
Subject Re: Unit testing
Date Wed, 26 Nov 2003 09:31:36 GMT
Ralph Goers wrote:
> Are you sure unit tests still work? They worked fine for me in 2.1RC1 but
> fail now.  I looked at ExcaliburTestCase and ran it through the debugger and
> don't see how it could possibly work.  All the calls to getClass() were
> replaced with ExcaliburTestCase.class.  Unless I am missing something this
> means it cannot possibly find test cases in classes that extend
> ExcaliburTestCase.
> 
> When I run my unit tests I get no tests found, which is what I would expect
> with that code.

Ah, I see what you mean. When I ran the tests myself I saw no failures, 
so I assumed they were OK, but I didn't check that some test cases 
reported "0 tests run".

What is strange, however, is that I wrote a couple of testcases for 
Woody 
(src/blocks/woody/test/org/apache/cocoon/woody/datatype/*TestCase.java) 
that do extend ExcaliburTestCase and I'm pretty sure that they do get 
executed!

Unfortunately, I'm not able to dig further into the problem ATM.

	Ugo


-- 
Ugo Cei - Consorzio di Bioingegneria e Informatica Medica
P.le Volontari del Sangue, 2 - 27100 Pavia - Italy
Phone: +39.0382.525100 - E-mail: u.cei@cbim.it


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message