cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Schatten <ala...@gmx.at>
Subject Re: CLI Still not working ... :-(
Date Wed, 12 Nov 2003 21:31:30 GMT
Simon Mieth wrote:

>i tested it with a CVS-build from last friday/sunday
>
>the steps i did:
>
>1.) copy your cocoon-day directory to build/webapp
>2.) add to the main-sitemap in build/webapp
>    as first pipeline in <map:pipelines>
>    <map:pipeline>
>    <map:match pattern="cocoon-day**">
>    <map:mount check-reload="yes" src="cocoon-day/"  uri-prefix="cocoon-day" />
>   </map:match> 
>  </map:pipeline>   
>3.) copy servlet-2.3.jar from tools/jetty/lib to build/webapp/WEB-INF/lib
>4.) ./cocoon.sh cli -c build/webapp -e false -d simon -C build/webapp/WEB-INF/cocoon.xconf
cocoon-day/index.html
>
>and the site was build after one trail without the "-e false" option, there was only generated
the index.html.
>Maybe that is the problem in your cli.xconf is this setting to true
><cocoon verbose="true"
>        follow-links="true"
>        precompile-only="false"
>        confirm-extensions="true">  <!-- this on set to false  -->
>
>
>  
>
thank you very much, now I come closer: but this thing is really strange:

I tried to do it with your commandline call:

./cocoon.sh cli -c build/webapp -e false -d simon -C 
build/webapp/WEB-INF/cocoon.xconf cocoon-day/index.html

and the result is lots of exceptions (which does not look good), but the 
result is correctly written to the destination directory, so I finally 
received one site-result, thank you.

however: it still does not work with the cli.xconf: though I have to 
add, that you were right with the confirm-extensions attriibute. what 
happens is the following: cocoon does not throw any exceptions, but a 
list like this:

* [1/11]    [11/12]   2.682s 4.6Kb   cocoon-day/index.html
* [2/10]    [0/0]     0.013s 149b    cocoon-day/bullet.png
* [3/9]     [0/0]     0.0050s 2.0Kb   cocoon-day/cocoon-built.gif
* [4/14]    [6/18]    0.27s  4.1Kb   cocoon-day/partner.html
* [5/13]    [0/0]     0.017s 1.4Kb   cocoon-day/wit_logo.gif
* [6/12]    [0/0]     0.0050s 1.2Kb   cocoon-day/sn_logo.gif
* [7/19]    [8/20]    0.409s 4.0Kb   cocoon-day/vortragende.html

and so on...

so it looks as if it would work, but *no* files are written, at least at 
no location where I could find them (I searched for them with find...)


??

can you understand this?


thank you *very much*


Alex


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message