cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Schatten <ala...@gmx.at>
Subject Impossible CLI??
Date Wed, 05 Nov 2003 18:33:47 GMT
So, I am playing around for hours now, to get the CLI running to produce 
an example for a demonstration... seems to be, that I am far too stupid 
to understand the documentation:

(1) I tried using a config file; then I detected, that there seem to be 
various modifications of the syntax: the example on the cocoon 2.1 
website does not work with my Cocoon 2.1 version, e.g. <uris> is not 
known... on the wiki there is an older documentation, which "works" 
without exception about not knowing certain elements.

(2) I also tried to use only command line options, however; I hardly 
understand what the uri concept and parameters...?!

(3) I came so far with e.g. the code below the line (and the same result 
with commanline options), that cocoon cli starts, but with the exceptions:

"Cannot find CatalogManager.properties"

??? and

"server.properties not found, using command line or default properties"


then comes:


"Opening database: 
/usr/java/jakarta-tomcat-5.0.9/webapps/cocoon/WEB-INF/db/cocoondb
HSQLDB server 1.7.1 is running
Use SHUTDOWN to close normally. Use [Ctrl]+[C] to abort abruptly"


and thats it; it does nothing but create two files in the work directory 
and waits until I terminate hsqldb with Ctrl C.


to be honest, I have no more ideas what to do?


thank you for help!


Alex



_____________________________________________________________________________________
./cocoon.sh cli -x /home/aschatt/test/cocoonday/cli2.conf


the cli2.conf file looks like this (comments removed):

<?xml version="1.0"?>
<cocoon verbose="true" 
        follow-links="true"
        precompile-only="false"
        confirm-extensions="false">
   <broken-links type="xml"
                 file="brokenlinks.xml"
                 generate="false"
                 extension=".error"/>
   <logging 
log-kit="/home/aschatt/tomcat5/webapps/cocoon/WEB-INF/logkit.xconf" 
logger="cli" level="ERROR" />
   <context-dir>/home/aschatt/tomcat5/webapps/cocoon</context-dir>
   
<config-file>/home/aschatt/tomcat5/webapps/cocoon/WEB-INF/cocoon.xconf</config-file>
   <work-dir>/home/aschatt/test/cocoonday/work</work-dir>
   <dest-dir>/home/aschatt/test/cocoonday/dest</dest-dir>
   <default-filename>index.html</default-filename>
   <accept>*/*</accept>
   <uri type="append"
        src-prefix="cocoon-day/"
        src="index.html"
        dest="cocoon-day"/>
</cocoon>


p.s.: I tried various combinations in the <uri> element, no one working. 
the website is on:

http://localhost:8080/cocoon/cocoon-day/index.html


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message