cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Schatten <>
Subject Impossible CLI??
Date Wed, 05 Nov 2003 18:33:47 GMT
So, I am playing around for hours now, to get the CLI running to produce 
an example for a demonstration... seems to be, that I am far too stupid 
to understand the documentation:

(1) I tried using a config file; then I detected, that there seem to be 
various modifications of the syntax: the example on the cocoon 2.1 
website does not work with my Cocoon 2.1 version, e.g. <uris> is not 
known... on the wiki there is an older documentation, which "works" 
without exception about not knowing certain elements.

(2) I also tried to use only command line options, however; I hardly 
understand what the uri concept and parameters...?!

(3) I came so far with e.g. the code below the line (and the same result 
with commanline options), that cocoon cli starts, but with the exceptions:

"Cannot find"

??? and

" not found, using command line or default properties"

then comes:

"Opening database: 
HSQLDB server 1.7.1 is running
Use SHUTDOWN to close normally. Use [Ctrl]+[C] to abort abruptly"

and thats it; it does nothing but create two files in the work directory 
and waits until I terminate hsqldb with Ctrl C.

to be honest, I have no more ideas what to do?

thank you for help!


./ cli -x /home/aschatt/test/cocoonday/cli2.conf

the cli2.conf file looks like this (comments removed):

<?xml version="1.0"?>
<cocoon verbose="true" 
   <broken-links type="xml"
logger="cli" level="ERROR" />
   <uri type="append"

p.s.: I tried various combinations in the <uri> element, no one working. 
the website is on:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message