cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Klamar <sebi+lists.cocoon-us...@tux.wh17.tu-dresden.de>
Subject Re: cocoon:/ does not work with SourceResolver (was: Re: Flow's processePipelineTo inside a Transformer?)
Date Wed, 26 Nov 2003 20:32:31 GMT
* Bruno Dumon [2003-11-26 14:29 +0100] wrote:
> On Wed, 2003-11-26 at 14:04, Sebastian Klamar wrote:
> > But for cocoon:/ and cocoon:// prefixed URLs (like
> > »cocoon://samples/«) I get no response.  The response has always
> > mime type text/xml and content length -1.
>
> Can you do source.getInputStream() and read data from the inputstream?

I can call source.getInputStream().available() that returns the same
size as source.getContentLength() with http:// URI.  But I can't make
reading from the InputStream.  I've tried the read() methods from
InputStream interface

  byte[] bytes;
  source.getInputStream().read(bytes);

and

  source.getInputStream().read(bytes, int, ...getInputStream().length)

but both are blocking the whole process and no data gets read.  I've
also tried to call close() on the InputStream.

Do you easily see what I'm doing wrong?  If not I can provide more
information about IOExceptions that were thrown when trying various
methods tomorrow (no read() but close(), only available() w/ and wo
close() ...).


TIA -- Sebastian

-- 
Dinge, die man nicht hören will, wenn man operiert wird:
                          »Und nun noch ein Bild aus der Richtung; Mann,
                                          das ist wirklich ein Monster.«
************************************************************************
PGP Key: 0x1E727CE6 / 9085 48BD 8332 4BFC D80C  A6CF D162 20BB 1E72 7CE6

Mime
View raw message