cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Wielgus <lis...@o2.pl>
Subject Another line break problem
Date Sat, 22 Nov 2003 18:55:45 GMT
Hello,

I have such a problem that I get unexpected linebreaks in the output, although there are no
<br/> tags in the html which is generated. 

For example in a XSP-file i have something like this:

<xsp:logic>
Date datum = new java.util.Date();
java.text.DateFormat df = java.text.DateFormat.getDateInstance(java.text.DateFormat.FULL);

</xsp:logic>
<lm-header>
<message>
    <xsp:expr>df.format(datum)</xsp:expr>:&#xa0;Hallo,&#xa0;<xsp-session-fw:getxml
context="authentication" path="/authentication/data/firstname"/>&#xa0;<xsp-session-fw:getxml
context="authentication" path="/authentication/data/lastname"/>
</message>
</lm-header>

in the xslt just:

<xsl:template match="lm-header">
    <b><xsl:apply-templates select="message"/></b>
</xsl:template>

But when the page is generated, the strings which are contained in the date format appear
in the different lines, as if there were <br/>'s but there aren't any.

So, I get for example:

Samstag, 22
November
2003: Hallo ...

instead of "Samstag, 22 November 2003: Hallo ..."

What can cause the problem?

Jan


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message