cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Heussen" <heus...@rheinland-online.com>
Subject Session attributes lost
Date Mon, 27 Oct 2003 16:12:26 GMT
Hi all,

Our environment:

* Win2K
* first Apache Tomcat/4.1.18 with JDK 1.3.1_07-b02
* Apache 2.0.44 in Front of the Tomcat an with mod_jk2 2.0.43 running for
load balancing
* JBoss 3.2.1 with a separate JDK 1.3.1_07 included a Tomcat 4.1.24


We have some strange losts of session attribute values. It seems that the
problem occurs in particular when the servers load is high. Our Cocoon 2.0.4
application stores each request parameter and any user given form data in
separate session attributes. Again and again it happens, that stored session
attributes are lost. In all cases the session itself seems to be valid. It
also happens that a date like "19.10.2000" stored in a session attribute
returns on getAttribute the value "19.10.". Mostly the informations stored
in session attributes are string objects.

I searched round about few days in different mailing lists for hints finding
a fix for this problem. It seems that we are not alone with this problem.
But still I did not find a answer :-(

Anybody out there who can turn us to the right direction to solve this
behavior?

Please help us!

Best regards, Markus


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message