cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: File uploads not working on Linux
Date Tue, 21 Oct 2003 12:54:39 GMT
Paul Bowler wrote:
> Yep. The configurations are identical as they come from the same build process.

Did you double check?  The reason I'm asking is that if your XP is local 
and allow-uploads are not set, uploads may appear to work under some 
circumstances because the file is local.  The other thing is to make 
sure the enctype of the form is set correctly.  If you have the samples 
running on the linux box, does the upload sample work?

Also, do you see any errors in Cocoon's logs?  If not, you may want to 
set your loglevel to DEBUG (it's much higher in 2.1) and see if there 
are any related messages.

Geoff

> P.S. I am using cocoon 2.1.
> 
> --
> Paul Bowler
> Aventix Associates Ltd
> 
> ---------- Original Message -----------
> From: Geoff Howard <cocoon@leverageweb.com>
> To: users@cocoon.apache.org
> Sent: Tue, 21 Oct 2003 08:13:53 -0400
> Subject: Re: File uploads not working on Linux
> 
> 
>>Paul Bowler wrote:
>>
>>>My cocoon application works fine using Jetty on Win XP, but as soon as I move
it to the Linux production box 
> 
> (using 
> 
>>>the same version of cocoon and Jetty with identical configurations) my FileUpload
action fails.
>>>
>>>The code to get the File from the request object is:
>>>
>>>Request request = ObjectModelHelper.getRequest(objectModel);
>>>Part part = (Part) request.get("filename");
>>>
>>>On XP the 'Part' object is gathered correctly. On Linux it is null.
>>
>>Is allow-uploads set correctly in web.xml on the linux box?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message