cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: Tomcat 4.1.24 and Cocoon 1.8.2
Date Fri, 03 Oct 2003 15:33:42 GMT
Josep Riudavets wrote:

> Yes, they can.
> 
> But you have to be careful with xerces version. J2SDK xerce version is older
> than the one that comes with cocoon. Try to put it into
> JDSDK/jre/lib/endorsed directory, replacing the older.

For Cocoon 1.8 I guess it's the other way around. Furthermore this is 
only a problem for JDK 1.4 or newer.

Joerg

> ----- Original Message -----
> From: "Martin Samm" <martins@image.net>
> 
>>I know this is an old version of cocoon, only it's the version as used by
> 
> mycgiserver.com. Can these versions of cocoon and tomcat be made to
> co-operate? I keep getting java.lang.VerifyError on the sample pages from,
> what i'm guessing is, various XML jar file clashes/interfaces, e.g.:
> 
>>java.lang.RuntimeException: Exception when creating "
> 
> org.apache.cocoon.parser.XercesParser" :
> 
>>java.lang.VerifyError: (class: org/apache/cocoon/parser/XercesParser,
> 
> method: parse signature: (Lorg/xml/sax/InputSource;Z)Lorg/w3c/dom/Document;)
> Incompatible object argument for function call
> 
>>at org.apache.cocoon.framework.Manager.create(Manager.java:124)
>>etc, etc
>>
>>I'd like to stick with the latest stable Tomcat, but i don't if it's
> 
> do-able
> 
>>Thanks
>>Martin Samm


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message