cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: Installation problems with Cocoon 2.1.M3 Tomcat 4.1.27 J2SDK 1.4.2
Date Thu, 02 Oct 2003 15:46:32 GMT
Stephanie Zohner wrote:
> Hi,
> 
> I tried in vain to install Cocoon. When I try to open the Cocoon welcome
> page I get an empty page.
> The Tomcat log shows the following stack trace:

...

> ----- Root Cause -----
> 
> java.lang.IllegalAccessError: class
> org.apache.xml.dtm.ref.sax2dtm.SAX2DTM2$AncestorIterator cannot access its
> superclass
> org.apache.xml.dtm.ref.DTMDefaultBaseIterators$InternalAxisIteratorBase

...

> My environment is:
> 
> Windows XP
> J2SDK 4.1.2
> Tomcat 4.1.27
> Cocoon 2.1. M3
> 
> I copied the xml libs in the common/endorsed directory of my tomcat
> installation.

Anything must be gone wrong with it. Your error is exactly the one at 
http://wiki.cocoondev.org/Wiki.jsp?page=EndorsedLibsProblem.

I suggest you to update your Cocoon version to 2.1.2, take the XML libs from 
its lib/endorsed directory and place them in TOMCAT_HOME/common/endorsed.

Does it work this time?

Joerg

-- 
System Development
VIRBUS AG
Fon  +49(0)341-979-7419
Fax  +49(0)341-979-7409
joerg.heinicke@virbus.de
www.virbus.de


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message