cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephanie Zohner" <stephanie.zoh...@gmx.at>
Subject Re: Antwort: RE: Using Saxon7.x in Cocoon2.1.x
Date Thu, 02 Oct 2003 09:55:15 GMT
Yes it does, see docs for details.

Cheers,

Stephanie
----- Original Message ----- 
From: <manfred.weigel@rzb.at>
To: <users@cocoon.apache.org>
Sent: Wednesday, October 01, 2003 6:26 PM
Subject: Antwort: RE: Using Saxon7.x in Cocoon2.1.x



Hi again!

Does Saxon7 require JDK 1.4 ?
I get a class not found ex: java/lang/CharSequence not found and seams to
be part of 1.4

thanks in advance
Manfred




roman.fleischer@siemens.com am 01.10.2003 16:29:21

Bitte antworten an users@cocoon.apache.org@inet

An:      users@cocoon.apache.org
Kopie:
Thema:   RE: Using Saxon7.x in Cocoon2.1.x


Hi Manfred

after some difficulties now i get a working version of saxon 7.6 and cocoon
2.1

Entries in the cocoon.xconf
<component role="org.apache.excalibur.xml.xslt.XSLTProcessor/Saxon"
class="org.apache.excalibur.xml.xslt.XSLTProcessorImpl"
logger="core.xslt-processor">
 <parameter name="use-store" value="false"/>
 <parameter name="incremental-processing" value="false"/>
 <parameter name="transformer-factory"
value="net.sf.saxon.TransformerFactoryImpl"/>
</component>
(i put this entry under the xalan component)

Entries in sitemap.xmap
<!-- Saxon transformer look at the new element: xslt-processor-role -->
<map:transformer name="xslt" pool-grow="2" pool-max="32" pool-min="8"
src="org.apache.cocoon.transformation.TraxTransformer">
 <use-request-parameters>false</use-request-parameters>
 <use-browser-capabilities-db>false</use-browser-capabilities-db>

<xslt-processor-role>org.apache.excalibur.xml.xslt.XSLTProcessor/Saxon</xslt

-processor-role>
</map:transformer>
(i renamed the original xslt-Transformer to "xalan")

Copy "saxon.jar" and "saxon7-jdom.jar" to the "WEB-INF/lib" of cocoon (i
renamed the saxon.jar to z-saxon.jar)
Now it should work.



-----Original Message-----
From: manfred.weigel@rzb.at [mailto:manfred.weigel@rzb.at]
Sent: Mittwoch, 1. Oktober 2003 16:14
To: users@cocoon.apache.org
Subject: Using Saxon7.x in Cocoon2.1.x



Hi all!

Has anybody a working sample config of cocoon.xconf and sitmap.xmap for
using Saxon7?
All my tries didnĀ“t work :-(

Version:    Cocoon 2.1.1
AppServer:  Websphere 4.03
OS:         AIX 4.3.3
Saxon:            7.6.5 (or 6.5.3)

thanks in advance!

Manfred





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org









---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message