cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mustafa Yalniz <yal...@bumed.org.tr>
Subject Re: web.xml listing="false" does not work
Date Fri, 12 Sep 2003 13:53:28 GMT
Hi,
Thanks for the response.

At 15:25 12.09.2003 +0200, you wrote:
> > But despite this we are still getting directory listing in case the
>user
> > enters URL with slash at the end.
>
>Are you sure that your sitemap for <application> does not include
>something like:
><map:match pattern="">
>     [some instruction to give a directory listing]
></map:match>

We do not have such a pipeline.

>You can prevent the listing problem by redirecting the request by addng
>the follwing to your sitemap for <application>
>
><map:match pattern="">
>     <map:redirect-to
>uri="<the-page-that-should-be-displayed-when-url-ends-with-slash>"/>
></map:match>

We have tried this and seems does not work.

>If you only have a cocoon level sitemap then include this:
><map:match pattern="application">
>     <map:redirect-to
>uri="application/<the-page-that-should-be-displayed-when-url-ends-with-s
>lash>"/>
></map:match>

We have this pipeline as well but does not work.





>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>For additional commands, e-mail: users-help@cocoon.apache.org

Thanks for the response again.

Best regards,
Mustafa


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message