cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: Cocoon and eclipse
Date Sat, 27 Sep 2003 11:45:26 GMT
Joerg Heinicke wrote:

> Geoff Howard wrote:
> 
>> Joerg Heinicke wrote:
>>
>>> Geoff Howard wrote:
>>>
>>>>> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>>>>
>>>> That's the one.  You can also set that property in the project 
>>>> directly.
>>>
>>> I have tried both
>>>
>>> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>>> in local.build.properties and
>>>
>>> <target name="properties" if="eclipse.running">
>>>   <property name="build.compiler" 
>>> value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
>>> </target>

...

>>> compile-deprecated:
>>>       [xpatch] BUILD FAILED: java.lang.IllegalArgumentException: No 
>>> attributes are implemented
>>>
>>> Don't know what I'm doing wrong.
>>
>> Hmmm.  I think that's a different error than if you don't have the 
>> property set at all.
> 
> There is no difference between having the property set or not.

Ok, I've just confirmed -- if you get rid of both of those properties 
(at least on my version of eclipse which is using 1.5.2) you do get a 
different error about the compiler version.

>> I have never gotten (or tried very hard) the full _cocoon_ build 
>> running within eclipse.
> 
> I simply tried it because of this thread. I didn't expect it to work.

:P

>> I have four or five other eclipse projects where ant works fine with 
>> that property set.  I'll dig in a little more.  If you get rid of the 
>> property do you get the error about the compiler (I forget what it says)?
> 
> As mentioned above. Echoing it immediately before the failure returns 
> the property value 'modern' set in build.properties.

I get the expected org.eclipse.jdt.core.JDTCompilerAdapter at least when 
setting it in the ant properties screen in eclipse.

>> The error you mention above does look familiar and I'm suspicious it 
>> has to do with ant revision level.  IIRC eclipse comes with a lower 
>> version than Cocoon and we may need it - possibly for the custom task 
>> xpatch which is mentioned there.
> 
> Only since Antonio's update to 1.5.4, Eclipse comes with 1.5.3 (at least 
> my 2.1.1). I have changed the classpath for the Ant task to Cocoon's 
> 1.5.4 (which is then also mentioned on the Eclipse console: "Building 
> with Apache Ant version 1.5.4 compiled on August 12 2003") and added 
> D:\cocoon-2.1\tools\anttasks to the classpath for Cocoon's Ant tasks.

Ok, I stand corrected but...

I now think this has to do with the endorsed dir or is at least limited 
to the xpatch task itself.  If you comment out the xpatch command in 
compile-deprecated things sail along swimmingly until the end when the 
next call to xpatch happens.  Even all the xsl transforms for the blocks 
build seem to work, though I didn't do build clean first.  I tried 
setting another property in the ant dialog for java.endorsed.dirs but 
that had no effect.

Anyone have an idea?  How can I modify the xpatch code to spit out debug 
info about what version of the xml endorsed dirs it gets?

Geoff


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message