cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomi Schuetz <tomischu...@yahoo.com>
Subject Problems with executing the 'site' and 'docs' task in cocoon
Date Tue, 30 Sep 2003 23:17:04 GMT
Hello all!

I'm very new to cocoon and it seems, that some obvious thinks are going wrong. I hope some
people
can give me a few hints.

I downloaded cocoon-2.1.1 for windows and unzipped it into a dev directory. After executing
the
inital task of the build.xml (which was successful) it wanted to create the 'site' and the
'docs'
tasks. Unfortunately they didn't work... :(

The output of the failed build is:

**********************************************************************************
forrest.checkhome:
forrest.home.present=true
build.properties.present=true

forrest:
Copying 1 file to
C:\Programme\cocoon-2.1.1\build\cocoon-2.1.1\documentation\xdocs\userdocs\installation

forrest:
Buildfile: C:\Programme\apache-forrest-0.4\forrest.build.xml
init-props:
Loading project specific properties from ${project.home}\forrest.properties
echo-settings:
examine-proj:
validation-props:
validate-skinconf:
load-project-props:
load-forrest-props:
init-skinprops:
Created dir: C:\Programme\cocoon-2.1.1\${project.home}\build\tmp
Reading filters from C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\skinfilters.properties
init:
bare-context:
____________________________________
Using skin forrest-site
____________________________________
Copying 180 files to C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context
Copying 45 files to C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context
Replacing: @skinconfig.year@ -> 2002
Replacing: @skinconfig.trail.link1.name@ -> apache
Replacing: @skinconfig.trail.link1.name@ -> apache
Replacing: @skinconfig.trail.link1.href@ -> http://www.apache.org/
Replacing: @skinconfig.trail.link2.name@ -> xml.apache
Replacing: @skinconfig.trail.link2.name@ -> xml.apache
Replacing: @skinconfig.trail.link2.href@ -> http://xml.apache.org/
Replacing: @skinconfig.trail.link3.name@ ->
Replacing: @skinconfig.trail.link3.name@ ->
Replacing: @skinconfig.trail.link3.href@ ->
Replacing: @skinconfig.year@ -> 2002
Replacing: @skinconfig.trail.link1.name@ -> apache
Replacing: @skinconfig.trail.link1.name@ -> apache
Replacing: @skinconfig.trail.link1.href@ -> http://www.apache.org/
Replacing: @skinconfig.trail.link2.name@ -> xml.apache
Replacing: @skinconfig.trail.link2.name@ -> xml.apache
Replacing: @skinconfig.trail.link2.href@ -> http://xml.apache.org/
Replacing: @skinconfig.trail.link3.name@ ->
Replacing: @skinconfig.trail.link3.name@ ->
Replacing: @skinconfig.trail.link3.href@ ->
Created dir: C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context\WEB-INF
Copying 2 files to C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context\WEB-INF
Replacing: @local-catalog@ ->
C:\Programme\cocoon-2.1.1\${project.home}\src\documentation\resources\schema\catalog
Replacing: @catalog-verbosity@ -> 1
Replacing: @skin@ -> forrest-site
Created dir: C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context\WEB-INF\lib
Created dir: C:\Programme\cocoon-2.1.1\${project.home}\build\tmp\context\WEB-INF\classes
check-contentdir:
BUILD FAILED
file://C:/Programme/apache-forrest-0.4/forrest.build.xml:522:
------------------------------------------------
ensure-content:
This project has no content in C:\Programme\cocoon-2.1.1\${project.home}\src\documentation.
Use the 'seed' target to create a template project structure.
------------------------------------------------
Total time: 7 seconds
Java Result: 1

docs:
Created dir: C:\Programme\cocoon-2.1.1\build\cocoon-2.1.1\docs

BUILD FAILED
file:C:/Programme/cocoon-2.1.1/src/targets/docs-build.xml:78:
C:\Programme\cocoon-2.1.1\build\cocoon-2.1.1\site not found.

Total time: 38 seconds

**********************************************************************************

It seems to me, that there is a problem with forrest. I do have forrest installed and if I'm
writting a simple forrest project I can generate it and everything is fine.

In the output I see the ${project.home} variable which could not be solved. In the property
and
build files 'project.home' is never set. My assumption is, that this value is passed dynamicly
to
forrest. After executing the 'site' or 'docs' task there is a directory generated by the name
of
${project.home}. But this can't be right... :(

Are my assumptions correct? How can I set the 'project.home' directory? Do I have to set it
at
all? Does anybody have an idea what I'm doing wrong?

Environment:
 - cocoon-2.1.1
 - forrest-0.4
 - ant-1.5.3-1
 - windows 2000

Thanks a lot for any help.

Best regards,
Tomi

__________________________________________________________________

Gesendet von Yahoo! Mail - http://mail.yahoo.de
Logos und Klingeltöne fürs Handy bei http://sms.yahoo.de

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message