cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josep Riudavets" <jriudave...@uoc.edu>
Subject Re: Cocoon + IXSIL
Date Mon, 29 Sep 2003 11:06:15 GMT
Ok, new versions of xalan, xerces and xml-apis ara now at
/tomcat/common/endorsed. And I have also placed them into
/j2sdk/jre/lib/ext/endorsed

But my problem is that Cocoon does not recognize IXSIL libraries !!!!!! I
add next line:

<xsp:include>iaik.ixsil.core.*</xsp:include>
<xsp:include>iaik.ixsil.algorithms.*</xsp:include>
<xsp:include>iaik.ixsil.init.*</xsp:include>
<xsp:include>iaik.ixsil.util.*</xsp:include>
<xsp:include>iaik.ixsil.keyinfo.X509.*</xsp:include>

And when I try to use these classes, Cocoon falls down :

org.apache.cocoon.components.language.LanguageException: Error compiling
procesa_xsp:
ERROR 1 (org/apache/cocoon/www/XSP/procesa_xsp.java):
...
iaik.security.provider.IAIK.addAsProvider(true);
		try{
// start error (lines 803-803) "IXSILInit cannot be resolved"
		IXSILInit.init(new URI("file", null,
"/usr/local/j2sdk1.4.1_02/IAIK-XML/init/properties/init.properties", null,
null));
// end error
 }catch(Exception ex){
	    ex.printStackTrace();

These classes ara packed into IXSIL_1_1_0_Evaluation.jar ... and I don't
know where to put this file, and what to do in order to Cocoon recognizes
it.






----- Original Message -----
From: "Antonio Gallardo" <agallardo@agsoftware.dnsalias.com>
To: <users@cocoon.apache.org>
Sent: Monday, September 29, 2003 12:09 PM
Subject: Re: Cocoon + IXSIL


> Josep Riudavets dijo:
> > I have removed next lines
> > <?cocoon-process type="xsp"?>
> > <?cocoon-process type="xslt"?>
> >
> > from my XSP page, because I'm using Cocoon 2.1.
> >
> > And this is the pipeline that I use to generate the page :
> >
> > <map:pipeline>
> > <map:match pattern="*.xsp">
> > <map:generate type="serverpages" src="XSP/{1}.xsp"/>
> > <map:transform src="XSL/{1}.xsl"/>
> > <map:serialize type="html"/>
> > </map:match>
> > </map:pipeline>
> >
> >
> > I think the problem resides in IXSIL libraries. These libraries are used
> > in order to implement XML-dSig stardard.
> >
> > When I created my class, it works perfectly. But when I try to use this
> > class from Cocoon, it does not recognize IXSIL libraries. Where do I
> > have to place IXSIL jars in order to be recognized by Cocoon? I have put
> > them into /WEB-INF/lib directory, but it is not enough. The jars that
> > form these libraries are:
> >
> > IXSIL_1_1_0_XXX.jar The actual IXSIL libraray.
> > xalan.jar
> > xml-apis.jar
> > runtime.jar
> > bsf.jar
> > xerces.jar
>
> Check this: http://wiki.cocoondev.org/Wiki.jsp?page=MigrateToCocoon2
>
> About the libraries... if you are using Tomcat 4.1.x, copy these files:
>
> xalan.jar
> xml-apis.jar
> xerces.jar
>
> in your $TOMCAT/common/endorsed directory.
>
> More info: http://wiki.cocoondev.org/Wiki.jsp?page=EndorsedLibsProblem
>
> Best Regards,
>
> Antonio Gallardo
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message