cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chance, Sam USA" <sgcha...@nps.navy.mil>
Subject Resource Not Found Message
Date Thu, 28 Aug 2003 00:33:29 GMT
Hi!
 
I recently upgraded my Tomcat version from 4.1.18 to 4.1.27 and I can no
longer access my Cocoon application.  I'm using Cocoon 2.0.4.  My main
sitemap includes the following mount to the sub sitemap:
 
<map:pipelines>
             <!--my mount for the route application sub-sitemap-->
             <map:pipeline>
                    <map:match pattern="route/**">
                           <map:mount uri-prefix="route"
src="route/sitemap.xmap" check-reload="yes" reload-method="synchron"/>
                    </map:match>
             </map:pipeline>
       .
       .
       .
</map:pipelines>
 
Here is the relevant snippet from the sub-sitemap:
 
<map:pipelines>
             <map:pipeline>
                    <map:match pattern="">
                           <map:redirect-to uri="index.html"/>
                    </map:match>
             </map:pipeline>
             <!-- <map:pipeline>
                    <map:match pattern="index.htm*">
                           <map:redirect-to uri="index.html"/>
                    </map:match>
             </map:pipeline>
       -->
             <map:pipeline>
                    <map:match pattern="index.html">
                           <map:generate type="file"
src="content/main.xml"/>
                           <map:transform type="xslt"
src="style/main.xsl"/>
                           <map:serialize type="html"/>
                    </map:match>
             </map:pipeline>
          .
          .
          .
</map:pipelines>
 
Can anyone explain what I'm doing wrong?  I simply upgraded Tomcat and
it no longer works.  I get "Cocoon 2 - Resource not found when I enter
http://localhost:8080/cocoon/route
 
Thank you!
Sam

Mime
View raw message