cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: EXSLT from exslt.org not working in 2.1
Date Tue, 26 Aug 2003 20:25:03 GMT
AFAIK it does not work with XSLTC in general, so you must at least use 
Xalan. We switched to Xalan as default XSLT processor just before the 
release, so I guess this is not the problem?

Until now I have never been using EXSLT extensions with Cocoon. I 
sometimes used Xalan Redirect Extension for debugging purposes.

Can you tell what exactly does not work? Do you use JDK 1.4 without any 
endorsed options? So the Xalan 2.2.D11 delivered with JDK 1.4 will be 
used - and this one has no EXSLT included.

Regards,

Joerg

Richard R. McKinley wrote:

> I am trying to use the exslt files from exslt.org in Cocoon 2.1.  I have 
> tried to use the most basic str:padding function and it will not 
> recognize that I have imcluded the str.xsl file.  I can't use the EXSLT 
> in template or function style.  Before any one says that Xalan-J 2.4+ 
> already has EXSLT, I want to use some functions like date:add that are 
> not in there.  Also, I want to use func:function and func:result which I 
> cannot get to work either.  Has anyone tried this?  I get errors when I 
> try, but between trying to make it work with Xalan, XSLTC, and Saxon I 
> would rather find someone who has made it work in the past rather than 
> have anyone help me trouble shoot.  A Google search shows me that this 
> is not an oft tried cobination.
> 
> Thanks,
> 
> RRM


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message