cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: conflicting batik versions in cocoon-2.1rc1 and its version of fop
Date Tue, 12 Aug 2003 07:40:36 GMT
Carsten,

is it already to late?

Joerg

neil wrote:
> Hi,
> Before the final cocoon-2.1 release
> is it possible to get the same version of batik used in cocoon and in its version of
fop?
> 
> Details...
> I've been trying out cocoon/fins/jfreechart/fop/batik to produce charts using scalable
pdf drawing commands so that the charts look
> good over a wide range of resolutions (e.g. screen and printer).
> 
> cocoon-2.1rc1 includes fop-0.20.5 and batik-1.5b5
> but fop-0.20.5 was built with batik-1.5b4
> and I think because of this I got in C:\jakarta-tomcat-4.1.24-LE-jdk14\logs/localhost_log.2003-08-12.txt:
> 
> ----- Root Cause -----
> java.lang.NoSuchMethodError:
> org.apache.batik.dom.svg.SAXSVGDocumentFactory.createDocument(Ljava/lang/String;Ljava/io/InputStream;)Lorg/apache/batik/dom/svg/SVGO
> MDocument;
> 	at org.apache.fop.image.analyser.SVGReader.loadImage(Unknown Source)
> 
> I got it working by rebuilding fop-0.20.5 from source after replacing its batik-1.5b4.jar
with cocoon's batik-1.5b5.jar
> (for good measure I also replaced its older xerces and xalan jars with cocoon's versions).


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message