cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mariusz Sieraczkiewicz" <mariusz-sieraczkiew...@o2.pl>
Subject Desperated about encoding issues
Date Mon, 04 Aug 2003 13:13:46 GMT
I'm really fond of using ISO-8859-2 encoding.
I've set both xml i html serializer to this encoding.
That's ok. Every generated paged is displayed properly
(also data from database). But I can't get through
proper encoding request parameters. The only way
I was able to do it correctly was xsp page (but I don't want
to be limited to it) and construction like
<xsp-request:get-parameter form-encoding="iso-8859-2" ...
                           ^^^^^^^^^^^^^^^^^^^^^^^^^^
(I've written about it, but there was no answer. I thought
it was a matter of DatabaseAction using, but it wasn't not.)

I tried to use SetCharacterEncodingAction:
<map:act type="set-encoding" >
    <map:parameter name="form-encoding" value="iso-8859-2" />
</map:act>
<!-- ..... and my operation, RequestGenerator for example -->

but it also didn't help.

Please help, I don't know encoding issue very well, but there is no
consistent description (in context of Cocoon).
(I've searched polish pl.comp.xml and a lot of people had similar
problem, not solved so far).

(Additional info: web.xml (of COcoon) form-encoding and container-encoding
set to utf-8 !! - the only good working setting with the others I've
described earlier.)
_____________________________
Best regards, Mariusz Sieraczkiewicz


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message