cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Gritsenko <vadim.gritse...@verizon.net>
Subject Re: Lucene XSP compilation problem
Date Sun, 13 Jul 2003 16:57:28 GMT
Upayavira wrote:

>>Upayavira wrote:
>>
>>    
>>
>>>I've got a problem with the "create index xsp" file. It works
>>>locally, and on my test tomcat, but on my live one it doesn't. As
>>>far as I know, they are all exactly the same systems. Can anyone
>>>interpret the below for me?
>>>      
>>>
>
>Thanks all for your comments. I also asked a friend to take a look on the server, and

>he spotted that the excalibur-datasource-1.1.1.jar was missing from the lib directory

>(using Cocoon 2.1m3). He commented taht it was previously in lib/core/jvmXX, but is 
>now in the database block. But I excluded the database block when building. 
>Uploading the jar to the server fixed it.
>
>My create-index.xsp is copied pretty much verbatim from the Lucene block example. 
>So why does the create-index.xsp require the datasource jar? That doesn't make 
>sense.
>  
>

It does not. See http://cocoon.apache.org/2.0/changes.html :

Decouple core XSP logicsheet from database classes to allow XSP 
deployment without excalibur datasource JAR file. If your XSP pages use 
datasources directly (and not through ESQL logicsheet), add xsp:include. 
(VG)


Vadim


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message