cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: No valid JdbcConnection class available with MySQL
Date Mon, 02 Jun 2003 11:47:05 GMT
At 10:53 PM 6/1/2003, you wrote:
>On Sunday, June 1, 2003, at 09:19  PM, Geoff Howard wrote:
>
>>Are the samples still in tact (I assume they are since this
>>is binary dist)?  If so, can you confirm that the database
>>samples (which use hsql) are working, or do you get the
>>same error?  If so, I'd guess that you may be using a
>>jdk 1.2/3 version of the excalibur database package.
>
>I don't remember what the error was, but I never did manage to get the 
>HSQLDB examples to work before, but I didn't worry too much about it 
>because I needed to get JDBC working anyway.
>
>Anyway, I finally got the newer version to install and copied all the 
>files I'd changed into it, and now it's WORKING! Both the HSQLDB examples 
>and the MySQL example. So it must have been the JDK 1.3 version I'd been 
>using. Good call.

For future reference: hsqldb _is_ jdbc.  If it's not working, then other 
databases
probably won't either because of the exact problem you found - the break 
between
jdk1.4 and previous versions that affects the excalibur datasource component.

>>Do a directory listing of your WEB-INF/lib - any jdk dependant
>>jars should give some clue as to which version they are.
>
>Now that I've got both versions here, I don't see any way to tell the two 
>apart by inspecting the .jar files in WEB-INF/lib. It might be a good idea 
>to write up a FAQ and make the two lib versions available for download. It 
>would sure be easier to replace the lib directory than try to reinstall 
>Cocoon. That was a real pain!

Not even by the name of the jar?  For instance, in 2.0.x for jdk1.4 the 
excalibur datasource
jar is called excalibur-datasource-vm14-20021121.jar.  The vm14 stands for 
"virtual machine version 1.4"  and I think the other is called *vm12*.

Glad things worked out,

Geoff 


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message